赞
踩
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8583 Accepted Submission(s): 3386
Problem Description
For a decimal number x with n digits (AnAn-1An-2 ... A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)
Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
Sample Input
3
0 100
1 10
5 100
Sample Output
Case #1: 1
Case #2: 2
Case #3: 13
Source
2013 ACM/ICPC Asia Regional Chengdu Online
Recommend
liuyiding | We have carefully selected several similar problems for you: 6437 6436 6435 6434 6433
题意:题目给了个f(x)的定义:F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1,Ai是十进制数位,然后给出a,b求区间[0,b]内满足f(i)<=f(a)的i的个数。
常规想:这个f(x)计算就和数位计算是一样的,就是加了权值,所以dp[pos][sum],这状态是基本的。a是题目给定的,f(a)是变化的不过f(a)最大好像是4600的样子。如果要memset优化就要加一维存f(a)的不同取值,那就是dp[10][4600][4600],这显然不合法。
这个时候就要用减法了,dp[pos][sum],sum不是存当前枚举的数的前缀和(加权的),而是枚举到当前pos位,后面还需要凑sum的权值和的个数,
也就是说初始的是时候sum是f(a),枚举一位就减去这一位在计算f(i)的权值,那么最后枚举完所有位 sum>=0时就是满足的,后面的位数凑足sum位就可以了。
仔细想想这个状态是与f(a)无关的(新手似乎很难理解),一个状态只有在sum>=0时才满足,如果我们按常规的思想求f(i)的话,那么最后sum>=f(a)才是满足的条件。
所以我们就逆向思维,考虑小于他的。
这题一定要用减法,这样最终的结果就会和f(A)无关(sum>=0)如果最后判断sum<=f(A)那么dp中还要记录f(A)
代码:
- #include<bits/stdc++.h>
- using namespace std;
- int dp[20][200000];
- int bit[20];
- int dfs(int pos,int num,bool flag)
- {
- if(pos == -1)
- return num >= 0;
- if(num < 0)///!!!
- return 0;
- if(!flag && dp[pos][num] != -1)
- return dp[pos][num];
- int ans = 0;
- int end = flag?bit[pos]:9;
- for(int i = 0;i <= end;i++)
- {
- ans += dfs(pos-1,num - i*(1<<pos),flag && i==end);
- }
- if(!flag)
- dp[pos][num] = ans;
- return ans;
- }
- int F(int x)
- {
- int ret = 0;
- int len = 0;
- while(x)
- {
- ret += (x%10)*(1<<len);
- len++;
- x /= 10;
- }
- return ret;
- }
- int A,B;
- int calc()
- {
- int len = 0;
- while(B)
- {
- bit[len++] = B%10;
- B/=10;
- }
- return dfs(len-1,F(A),1);
- }
- int main()
- {
- int T;
- int iCase = 0;
- scanf("%d",&T);
- memset(dp,-1,sizeof(dp));
- while(T--)
- {
- iCase++;
- scanf("%d%d",&A,&B);
- printf("Case #%d: %d\n",iCase,calc());
- }
- return 0;
- }
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。