赞
踩
Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 109769 Accepted Submission(s): 42754
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5 green red blue red red 3 pink orange pink 0
Sample Output
red pink
import java.io.*;
import java.util.*;
public class Main{
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
while (cin.hasNext()) {
int n = cin.nextInt();
if(n==0){break;}
n++;
String[] a = new String[n];
String[] b = new String[n];
int[] c = new int[n];
int max = 1;
int end = 1;
for (int i = 0; i < n; i++) {
a[i] = cin.nextLine();
b[i] = a[i];
}
for (int j = 0; j < n; j++) {
for (int i = j; i < n; i++) {
if (b[j].equals(a[i])) {
c[j]++;
}
}
if (c[j] > max) {
max = c[j];
end = j;
}
}
System.out.println(a[end]);
}
}
}
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。