搜索
查看
编辑修改
首页
UNITY
NODEJS
PYTHON
AI
GIT
PHP
GO
CEF3
JAVA
HTML
CSS
搜索
Cpp五条
这个屌丝很懒,什么也没留下!
关注作者
热门标签
jquery
HTML
CSS
PHP
ASP
PYTHON
GO
AI
C
C++
C#
PHOTOSHOP
UNITY
iOS
android
vue
xml
爬虫
SEO
LINUX
WINDOWS
JAVA
MFC
CEF3
CAD
NODEJS
GIT
Pyppeteer
article
热门文章
1
【题解】第八届蓝桥杯(国赛)·瓷砖样式·C/C++·DFS(中转点)_c++瓷砖问题
2
Blueprint教程_pcb blueprint
3
【FPGA】使用Verilog编程通过ModelSim实现2FSK调制解调仿真③(信号调制仿真)_fsk解调 verilog
4
android文件存储的几种方式,Android本地存储的几种方式
5
【头歌-Python】Python第五章作业(初级)_头歌-python】python第五章作业(初级)
6
Linux dmesg命令教程:深入理解内核消息(附案例详解和注意事项)_dmesg 最重要的信息
7
maven下载、配置、使用方法(mac)_mac下载maven
8
git下载,切换,合并,删除分支_切换分支并下载
9
基于PyTorch的线性回归的简洁实现_pytorch线性回归代码
10
IIR数字滤波器简介与实现
当前位置:
article
> 正文
实验四:静态路由配置_实验4 静态、默认及汇聚路由
作者:Cpp五条 | 2024-05-16 09:37:10
赞
踩
实验4 静态、默认及汇聚路由
1.
静态路由
(
一般配置
)
【实验名称】静态路由配置
【实验目的】掌握静态路由的配置方法,理解路由表的作用和原理
【实验设备】路由器(
2
台)、计算机(
2
台)、交叉线(
2
根)、
DCE
串口线缆(
1
根)
【实验拓扑】实验拓扑如图
1
所示。
【技术原理】
路由表的产生方式一般有
3
种。
(
1
)直连路由:给路由器接口直接配置
IP
地址,路由器自动产生本接口
IP
所在网段的路由
信息。
(
2
)静态路由:通过手工方式配置本路由器未知网段的路由信息,适用于拓扑结构简单的
网络中。
(
3
)动态路由协议学习产生路由:通过在路由器上运行动态路由协议,路由器之间互相自
动学习产生路由信息,适用于大规模网络或网络拓扑相对复杂的情况。
在图
1
所示的网络中,路由器
Routera
和
Routerb
连接了
192.168.1.0 /24
、
192.168.2.0/24
和
192.168.3.0/24
三个网段,通过在两台路由器上配置静态路由,实现
3
个网段互通。对于
Routera
,
192.168.1.0
、
192.168.3.0
网段属于直连网段,不需要配置,只配置到达
192.168.2.0
网段的路由即可。同理,在
Routerb
上只配置到达
192.168.1.0
网段的路由即可。最后通过
PCA
、
PCB
相互
ping
通进行验证。
【实现功能】
3
个网段互通
【实验步骤】
(
1
)参照图
1
所示连线,配置
PCA
和
PCB
的
IP
地址、子网掩码和网关。
(
2
)基本配置。
routera
基本配置。
Routera>enable
Routera#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Routera(config)#interface FastEthernet0/0
Routera(config-if)#ip address 192.168.1.2 255.255.255.0
Routera(config-if)#no shutdown
Routera(config-if)#exit
Routera(config)#interface Serial2/0
Routera(config-if)#ip address 192.168.1.1 255.255.255.0
Routera(config-if)#clock rate 64000
Routera(config-if)#no shutdown
Routera(config-if)#end
Routera#show ip interface brief !
参数
brief
表示查看接口
IP
的概况
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.1 YES manual up up
FastEthernet1/0 unassigned YES unset administratively down down
Serial2/0 192.168.1.1 YES manual down down
Serial3/0 unassigned YES unset administratively down down
FastEthernet4/0 unassigned YES unset administratively down down
FastEthernet5/0 unassigned YES unset administratively down down routerA#show
interface
Routerb
基本配置。
Routerb>enable
Routerb#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Routerb(config)#interface Serial3/0
Routerb(config-if)#ip address 192.168.1.2 255.255.255.0
Routerb(config-if)# no shutdown
Routerb(config-if)#exit
Routerb(config)#interface FastEthernet0/0
Routerb(config-if)#ip address 192.168.2.1 255.255.255.0
Routerb(config-if)#no shutdown
Routerb(config-if)#end
Routerb#
(
3
)静态路由配置。
在
Routera
上配置到达
192.168.2.0
网段的静态路由。
Routera(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.2
Routera(config)#end
Routera#show ip route !
查看路由表
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.1.0/24 is directly connected, FastEthernet0/0
S 192.168.2.0/24 [1/0] via 192.168.3.2
C 192.168.3.0/24 is directly connected, Serial2/0
在
Routerb
上配置到达
192.168.1.0
网段的静态路由。
Routerb#configure terminal
Routerb(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1
Routerb(config)#end
Routerb#show ip route !
查看路由表
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external ty
pe 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
S 192.168.1.0/24 [1/0] via 192.168.3.1
C 192.168.2.0/24 is directly connected, FastEthernet0/0
C 192.168.3.0/24 is directly connected, Serial3/0
.
(
4
)测试。
测试主机
A
和主机
B
是否
Ping
通
(
5
)如需要删除静态路由:
Routera(config)# no ip route 192.168.2.0 255.255.255.0
作业(使用静态路由实现全部主机互相通信)
1.
静态路由
(
默认路由
)
默认路由的配置方式与静态路由相同,目标地址为 0.0.0.0,子网掩码为 0.0.0.0,代
表所有网络。在路由匹配时,只有路由表中的其他表项都不匹配时才选择默认路由。默认路
由可手工配置,也可由路由协议产生。
在 routerA 上配置默认路由
routerA#conf t
routerA(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.3
routerA(config)#end
routerA#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 192.168.2.3 to network 0.0.0.0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet1/0
S* 0.0.0.0/0 [1/0] via 192.168.2.3
在 routerb 上配置默认路由
RouterB>en
RouterB#conf ter
RouterB(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
RouterB(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.3
RouterB(config)#end
RouterB#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 192.168.3.3 to network 0.0.0.0
S 192.168.1.0/24 [1/0] via 192.168.2.1
C 192.168.2.0/24 is directly connected, FastEthernet0/0
C 192.168.3.0/24 is directly connected, FastEthernet1/0
S* 0.0.0.0/0 [1/0] via 192.168.3.3
在 routerc 上配置默认路由
RouterC(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1
RouterC(config)#ip route 192.168.2.0 255.255.255.0 192.168.3.1
RouterC(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.3
RouterC(config)#end
RouterC#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 192.168.4.3 to network 0.0.0.0
S 192.168.1.0/24 [1/0] via 192.168.3.1
S 192.168.2.0/24 [1/0] via 192.168.3.1
C 192.168.3.0/24 is directly connected, FastEthernet0/0
C 192.168.4.0/24 is directly connected, FastEthernet1/0
S* 0.0.0.0/0 [1/0] via 192.168.4.3
在 routerd 上配置静态路由
RouterD(config)#ip route 192.168.1.0 255.255.255.0 192.168.4.1
RouterD(config)#ip route 192.168.2.0 255.255.255.0 192.168.4.1
RouterD(config)#ip route 192.168.3.0 255.255.255.0 192.168.4.1
测试:各网段互通。
作业(使用默认路由,使全部主机互相通信)
声明:
本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:
https://www.wpsshop.cn/w/Cpp五条/article/detail/578070
推荐阅读
article
哈希
表
(散列
表
)——C++
数据结构
详解_
哈希
表
数据结构
代码
c++
...
散列
表
(Hash table,也叫
哈希
表
),是根据关键码值(Key value)而直接进行访问的
数据结构
。也就是说,它通...
赞
踩
article
Visual
Studio
Code
插件
整理大全_
vscode
的
icon
fonts
插件
...
ESLint(格式化程序和规范代码)如果你需要格式化程序和规范代码,那么这个
插件
适合你。它可以自动格式化你的代码并查找代...
赞
踩
article
mcs
的
文件格式
_
mcs
转
hex
...
DescriptionThe iMPACT software can be used to generate the f...
赞
踩
article
hbuild
的
uniapp
项目
打包
到 h5 部署到
服务器
_
uniapp
打包
到
服务器
...
1、
uniapp
项目 (一般改3 个地方)
_
uniapp
打包
到
服务器
uniapp
打包
到
服务器
1...
赞
踩
article
1
-
4
GPIO
输入
模式(ARM-
GD32
)...
电路分析:按键的一端连接到GND一端连接上拉电阻接3.3V电源,有一个R53的限流电阻用于保护IO口,C
4
4
使用了一个
1
...
赞
踩
article
如何
定时
发
布
朋友圈
?_
微信
定时
发
朋友圈
怎么设置
的
...
分享有价值
的
信息、促销活动或优惠券等内容,可以增强客户
的
粘性和忠诚度,进而促使他们进行再次购买或推荐给其他人。分享行业动...
赞
踩
article
redis
与
memcache
区别_
memcache
redis
区别...
1)性能对比:由于Redis只使用单核,而Memcached可以使用多核,所以平均每一个核上Redis在存储小数据时比M...
赞
踩
article
数据结构
(三)
算法
...
提高解决问题方法的效率,要提高
算法
的巧妙程度,减少计算量,用更多的加减法代替乘除法。
数据结构
(三)
算法
...
赞
踩
article
docker
overlay
扩容...
文件系统使用率已接近100%,导致写不了数据。
docker
overlay
扩容 ...
赞
踩
article
Linux
进阶
指令
笔记(一)
_
linux
lines
...
Linux
_
linux
lines
linux
lines
df
指令
作...
赞
踩
article
uniapp
实现H5
打
包
_
uniapp
打
h5
包...
1.找到manifest.json—
h5
配置2.点击发行—H5
打
包
3.配置一下4.双击
打
开
打
包
好的H55.
打
包
发给后端_...
赞
踩
article
基于
PPYOLO
的
智能
害虫
防治
机器人
_
有害生物
智能
识别...
该项目通过对大数据、
智能
识别、深度学习等技术的应用,针对常见林业
害虫
,能够通过
智能
巡检
机器人
实时识别
害虫
并对其分析处理,...
赞
踩
article
Python
在
编程语言
中是
什么
地位
?为
什么
很多
大学
不教
Python
?_
python
的
地位
...
随着这两年人工智能大热,作为AI届
的
“网红”,
Python
的
地位
也有一定变化,所以今天再把这个问题扒出来研究一下。Pyt...
赞
踩
article
微信
小
程序
文本
内容
安全
检测
_如何测试
小
程序
是否
安全
...
微信
小
程序
官方对于那种可以发布
内容
的
小
程序
,管控得比较严,所以要做类型以发帖、论坛类的
小
程序
都要做
内容
安全
检测
。所以想要...
赞
踩
article
C#
调用
ML
.
NET
(机器学习、
人工智能
预测)_
c#
ml...
我使用的VS2019版本,具体安装过程就不赘述了这边我已经安装完了,就不演示了,安装过程可以自行。后面我来展示下如何引用...
赞
踩
article
我
的
创作
纪念日
—
—
文章
汇总
...
不知不觉,从写第一篇博客到今天,已经过去三年了,在此对我所有
的
博文进行整理和
汇总
,方便快速查询。我
的
创作
纪念日
—
—
文章汇...
赞
踩
article
Xilinx
Bit
文件
格式详解_fpga 直接下载
bit
文件
...
文章目录
Xilinx
Bit
文件
如何生成
Xilinx
Bit
文件
格式参考资料
Xilinx
FPGA支持多种程序
文件
格式,...
赞
踩
article
如何安装
pycharm
解释器
,
pycharm
安装
解释器
...
安装包下载完成之后,点击“Customize installation”,进行自定义安装,弹出的框口中采用默认设置,如下...
赞
踩
article
活动
图
、类
图
、顺序
图
、
状态
图
...
类class的定义具有相同属性、 操作、 方法、 关系或者行为的一组对象的描述符类是真实世界事物的抽象问题领域的类: 在...
赞
踩
article
【
头歌
-
Python
】
Python
第五章
作业
(
初级
)_
头歌
-
python
】
python
第五章
作业
(初...
【代码】【
头歌
-
Python
】
Python
第五章
作业
(
初级
)_
头歌
-
python
】
python
第五章
作业
(
初级
)
头歌
-p...
赞
踩
相关标签
数据结构
散列表
c++
vscode
visual studio code
uni-app
arm开发
stm32
单片机
嵌入式硬件
c
微信
科技
算法
docker
大数据
html5
人工智能
机器学习
paddlepaddle
transformer
深度学习
python
Python入门