当前位置:   article > 正文

C++ 02-线性结构2 一元多项式的乘法与加法运算_02-线性结构2 一元多项式的乘法与加法运算c++

02-线性结构2 一元多项式的乘法与加法运算c++

02-线性结构2 一元多项式的乘法与加法运算

设计函数分别求两个一元多项式的乘积与和。

输入格式:

输入分2行,每行分别先给出多项式非零项的个数,再以指数递降方式输入一个多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:

输出分2行,分别以指数递降方式输出乘积多项式以及和多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。零多项式应输出0 0。

输入样例:

4 3 4 -5 2 6 1 -2 0
3 5 20 -7 4 3 1

输出样例:

15 24 -25 22 30 21 -10 20 -21 8 35 6 -33 5 14 4 -15 3 18 2 -6 1
5 20 -4 4 -5 2 9 1 -2 0


  我刚开始学数据结构,可能做法有点笨……哔了狗的题我真的是……(´°̥̥̥̥̥̥̥̥ω°̥̥̥̥̥̥̥̥`)

#include<iostream>
#include<cmath>
using namespace std;

struct node
{
    int xs,zs;
    node *next;
};

node *read()    
{
    int n;
    cin>>n;
    node *head=new node;
    head->next=NULL;
    for(int i=0;i<n;i++)
    {
        node *r=head;
        node *s=new node;
        cin>>s->xs>>s->zs;
        if (s->xs!=0)//系数不为0插入链表
        {
            while (r->next!=NULL&&r->next->zs>=s->zs)//按照指数大小有序插入
            {
                r=r->next;
            }
            if (r->zs==s->zs)
            {
                r->xs+=s->xs;
            }
            else
            {
                s->next=r->next;
                r->next=s;
            }
        }
    }
    return head;
}

void print(node *head)  //输出链表
{
    node *p=head->next;
    if (p==NULL)
    {
        cout<<"0 0";
    }
    else
    {
        while(p)
        {
            cout<<p->xs<<" "<<p->zs;
            if (p->next)
            {
                cout<<" ";
            }
            p=p->next;
        }
    }
    cout<<endl;
}

node *add(node *a,node *b)  //相加链表
{
    node *head=new node;
    head->next=NULL;
    node *p=a->next;
    node *q=b->next;
    node *r=head;
    while (p!=NULL&&q!=NULL)
    {
        node *s=new node;
        s->next=NULL;
        if (p->zs>q->zs)
        {
            s->zs=p->zs;s->xs=p->xs;
            r->next=s;
            r=r->next;
            p=p->next;
        }
        else if (p->zs<q->zs)
        {
            s->zs=q->zs;s->xs=q->xs;
            r->next=s;
            r=r->next;
            q=q->next;
        }
        else
        {
            s->zs=q->zs;s->xs=q->xs+p->xs;
            if (s->xs!=0)
            {
                r->next=s;
                r=r->next;
            }
            p=p->next;
            q=q->next;
        }
    }
    if (p!=NULL)
    {
        r->next=p;
    }
    else
    {
        r->next=q;
    }
    return head;
}

node *mul(node *a,node *b)  //  链表相乘
{
    node *p=a->next;
    node *q=b->next;
    node *head=new node;
    head->next=NULL;
    while(p!=NULL)
    {
        while(q!=NULL)
        {
            node *s=new node;
            s->next=NULL;
            s->zs=p->zs+q->zs;
            s->xs=p->xs*q->xs;
            node *r=head;
            while(r->next!=NULL&&r->next->zs>=s->zs)
                r=r->next;
            if (r->zs==s->zs)
            {
                r->xs+=s->xs;
                if (r->xs==0)
                {
                    node *f=head;
                    while (f->next!=r)
                    {
                        f=f->next;
                    }
                    f->next=r->next;r=f;
                }
            }
            else
            {
                s->next=r->next;
                r->next=s;
            }
            q=q->next;
        }
        p=p->next;
        q=b->next;
    }
    return head;
}

int main()
{
    node *L1,*L2;
    L1=read();
    L2=read();
    node *sum;
    sum=add(L1,L2);
    node *m;
    m=mul(L1,L2);
    print(m);
    print(sum);
    return 0;
}
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
  • 84
  • 85
  • 86
  • 87
  • 88
  • 89
  • 90
  • 91
  • 92
  • 93
  • 94
  • 95
  • 96
  • 97
  • 98
  • 99
  • 100
  • 101
  • 102
  • 103
  • 104
  • 105
  • 106
  • 107
  • 108
  • 109
  • 110
  • 111
  • 112
  • 113
  • 114
  • 115
  • 116
  • 117
  • 118
  • 119
  • 120
  • 121
  • 122
  • 123
  • 124
  • 125
  • 126
  • 127
  • 128
  • 129
  • 130
  • 131
  • 132
  • 133
  • 134
  • 135
  • 136
  • 137
  • 138
  • 139
  • 140
  • 141
  • 142
  • 143
  • 144
  • 145
  • 146
  • 147
  • 148
  • 149
  • 150
  • 151
  • 152
  • 153
  • 154
  • 155
  • 156
  • 157
  • 158
  • 159
  • 160
  • 161
  • 162
  • 163
  • 164
  • 165
  • 166
  • 167
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/weixin_40725706/article/detail/342854
推荐阅读
相关标签
  

闽ICP备14008679号