当前位置:   article > 正文

第十届——特别数的和(Java)_java实现。小明对数位中含有2、0、1、8的数字很感兴趣,在1到40中这样的数包括1、2

java实现。小明对数位中含有2、0、1、8的数字很感兴趣,在1到40中这样的数包括1、2

小明对数位中含有2、0、1、9的数字很感兴趣(不包括前导0),在1到40中这样的数包括1、2、9、10至32、39和40,共28个,他们的和是574。 请问,在1到n中,所有这样的数的和是多少?
【输入格式】输入一行包含两个整数 n。
【输出格式】输出一行,包含一个整数,表示满足条件的数的和。
【样例输入】40
【样例输出】574

解析

只要从1到n中,找到包含“1”,“2”,“9”,“0”这样的数,把他们全部加起来,就可以了
写法一

public class Main {
	static List<Integer> list = new ArrayList<Integer>();

	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		int n = input.nextInt();
		long sum = 0;
		SearchNum(n);
		for (int i : list) {
			sum += i;
		}
		System.out.println(sum);

	}

	static public void SearchNum(int n) {
		for (int i = 1; i <= n; i++) {
			int tempI = i;
			while (tempI != 0) {
				int temp = tempI % 10;
				if (temp == 1 || temp == 2 || temp == 9 || temp == 0) {
					list.add(i);
					break;
				}
				tempI /= 10;
			}
		}
		System.out.println(list);
	}
}

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31

写法二:改进

public class 特别数的和 {
	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		int n = input.nextInt();
		long sum = 0;
		for (int i = 1; i <= n; i++) {
			int tempI = i;
			while (tempI != 0) {
				int temp = tempI % 10;
				if (temp == 1 || temp == 2 || temp == 9 || temp == 0) {
					sum += i;
					break;
				}
				tempI /= 10;
			}
		}
		System.out.println(sum);
	}
}
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19

做题反思

能够做出来的就慢慢做,尽量优化。不要想的太复杂,相信自己能解决。

end.

声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/你好赵伟/article/detail/302961
推荐阅读
相关标签
  

闽ICP备14008679号