当前位置:   article > 正文

规律_0.142857的规律

0.142857的规律

B - Number Sequence
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A number sequence is defined as follows: 

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

Given A, B, and n, you are to calculate the value of f(n). 
 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed. 
 

Output

For each test case, print the value of f(n) on a single line. 
 

Sample Input

       
       
1 1 3 1 2 10 0 0 0
 

Sample Output

       
       
2 5
 


#include<stdio.h>

int main()
{
     long long s[101];
int a,b,n,T;
     while(scanf("%ld%ld%ld",&a,&b,&n)&&(a!=0&&b!=0&&n!=0))
     {
        int i,j,T;
        s[1]=1;
        s[2]=1;
        for(i=3;i<101;i++){


            s[i]=(a*s[i-1]+b*s[i-2])%7;
            for(j=1;j<i-1;j++)
            {
                if(s[j-1]==s[i-1]&&s[j]==s[i]){
                    T=i-j;
                    break;
                }
            }
        }
        n = n%T;
        printf("%ld\n",s[n]);
     }
     return 0;
}


声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/凡人多烦事01/article/detail/302749
推荐阅读
相关标签
  

闽ICP备14008679号