赞
踩
输入格式 :输入一个整数 n。(1≤n≤15)
输入样例:
3
输出样例:
- 3
- 2
- 2 3
- 1
- 1 3
- 1 2
- 1 2 3
答案
- #include<iostream>
- using namespace std;
- const int N=15;//设置定值
- int n;
- bool used[N];//判断是否使用该值
- void dfs(int u){
-
- if(u>n){
- for(int i=1;i<=n;i++)
- if(used[i]) cout<<i<<" ";//如果该值被定义为true,就输出i
- cout<<endl;
- return;
- }
-
- dfs(u+1); //进入 u=n
- used[u]=true;//将此值定义为true
- dfs(u+1);//再次进入
- used[u]=false;//初始化
-
- }
-
- int main(){
- cin>>n;
- dfs(1);
- return 0;
- }
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。