赞
踩
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 10591 | Accepted: 4543 |
Description
Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di <L).
To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.
Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).
FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.
Input
Output
Sample Input
25 5 2 2 14 11 21 17
Sample Output
4
Hint
Source
一条河长度为 L,河的起点(Start)和终点(End)分别有2块石头,S到E的距离就是L。河中有n块石头,每块石头到S都有唯一的距离问现在要移除m块石头(S和E除外),每次移除的是与当前最短距离相关联的石头,要求移除m块石头后,使得那时的最短距离尽可能大,输出那个最短距离。
思路:用二分枚举最小距离。找到最优解
- #include<stdio.h>
- #include<string.h>
- #include<algorithm>
- using namespace std;
- int main()
- {
- int i,j,l,m,n,dist[51000];
- while(scanf("%d%d%d",&l,&n,&m)!=EOF)
- {
- memset(dist,0,sizeof(dist));
- dist[0]=0;
- dist[n+1]=l;
- int low=l;
- int high=l;
- for(i=1;i<=n+1;i++)
- {
- if(i<=n)
- scanf("%d",&dist[i]);
- if(low>dist[i]-dist[i-1])
- low=dist[i]-dist[i-1];
- }
- sort(dist,dist+n+2);
- while(low<=high)
- {
- int mid=(low+high)/2;
- int num=0;
- int sum=0;
- for(i=1;i<=n+1;)
- {
- if((sum+=dist[i]-dist[i-1])<=mid)
- {
- i++;
- num++;
- }
- else
- {
- i++;
- sum=0;
- }
- }
- if(num<=m)//注意,当num==m时也不一定是最优解
- {
- low=mid+1;
- }
- else
- {
- high=mid-1;
- }
- }
- printf("%d\n",low);
- }
- return 0;
- }
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。