当前位置:   article > 正文

算法竞赛入门经典(第2版) All in All UVa 10340_all in all算法

all in all算法

All in All UVa 10340

—————————————————————————
题目:UVa10340
—————————————————————————

思路:将两个字符串逐位比较,pos记录其位置,若pos=字符串s长度则成功。

**Sample Input**
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

**Sample Output**
Yes
No
Yes
No
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
#include<bits/stdc++.h>
#define maxn 10000000
using namespace std;
int main() {
	char s[maxn], t[maxn];
	while(scanf("%s%s", s, t) != EOF) {
		int len_S = strlen(s);
		int len_T = strlen(t);
		int pos = 0;
		for(int i = 0; i < len_T; i++) {
			if(t[i] == s[pos]) 
				pos ++;
		}
		if(pos == len_S) {
			printf("Yes\n");
		}
		else printf("No\n");
	}
	return 0;
} 
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/天景科技苑/article/detail/1004867
推荐阅读
相关标签
  

闽ICP备14008679号