当前位置:   article > 正文

PTA-还原二叉树_还原二叉树pta

还原二叉树pta

一、题目

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

输入格式:
输入首先给出正整数N(≤50),为树中结点总数。下面两行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区别大小写)的字符串。

输出格式:
输出为一个整数,即该二叉树的高度。

输入样例:
9
ABDFGHIEC
FDHGIBEAC
输出样例:
5

二、代码及解析

两步完成:
①已知前序和中序还原二叉树
BTree recPreIn(char Pre[],char In[],int len)函数递归完成
其中len表示Pre和In的长度,由于字符串截取使用指针实现,使用len来记录长度方便进行递归
②计算高度
int getHeight(BTree T) 数据结构二叉树的经典算法,返回二叉树的高度。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
typedef struct node{
    char data;
    struct node *Left,*Right;
}BNode,*BTree;
BTree recPreIn(char Pre[],char In[],int len){
    if(len==0) return NULL;
    BTree T=(BTree)malloc(sizeof(BNode));
    T->data=Pre[0];
    int n=-1;
    for(int i=0;i<strlen(In);i++){
        if(In[i]==Pre[0]){
            n=i;break;
        }
    }
    T->Left=recPreIn(Pre+1,In,n);
    T->Right=recPreIn(Pre+n+1,In+n+1,len-n-1);
    return T;
}
int getHeight(BTree T)  
{  
    if(T == NULL)   return 0;  
    int lt = getHeight(T->Left);   
    int rt = getHeight(T->Right);  
    int n = lt; if(rt>n) n=rt;
    return n + 1;   
}  
int main(){
    int n;scanf("%d",&n);
    char s1[60],s2[60];
    scanf("%s%s",&s1,&s2);
    BTree T=recPreIn(s1,s2,n);
    int h=getHeight(T);
    printf("%d",h);
}
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/小丑西瓜9/article/detail/663481
推荐阅读
相关标签
  

闽ICP备14008679号