当前位置:   article > 正文

7-1 根据后序和中序遍历输出先序遍历 (25分) PTA_7-1 树的遍历 分数 25 作者 陈越 单位 浙江大学 给定一棵二叉树的后序遍历和中序

7-1 树的遍历 分数 25 作者 陈越 单位 浙江大学 给定一棵二叉树的后序遍历和中序

本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。

输入格式:
第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。

输出格式:
在一行中输出Preorder: 以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
Preorder: 4 1 3 2 6 5 7

AC代码

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

template <class DataType>
struct BiNode
{
 	DataType data;
  	BiNode<DataType> *lchild, *rchild;
  	BiNode(DataType n){
        data=n;
        lchild=NULL;
        rchild=NULL;
  	}
};

template <class DataType>
class BiTree
{
public:
    BiTree()
    {
        int n,i;
        cin>>n;
        int *h,*z;
        h=new int[n];
        z=new int[n];
        for(i=0; i<n; i++)
        {
            cin>>h[i];
        }
        for(i=0; i<n; i++)
        {
            cin>>z[i];
        }
        root = Creat(h,z,n);
    }
  	void PreOrder( ){PreOrder(root);}

private:
  	BiNode<DataType> *Creat(DataType *h,DataType *z,int n);       //构造函数调用
    BiNode<DataType> *root;
    void PreOrder(BiNode<DataType> *bt);                              //指向根结点的头指针

};
int c=0;
template <class DataType>
void BiTree<DataType> :: PreOrder(BiNode<DataType> *bt)
{
	if (bt == nullptr) return;              //递归调用的结束条件
	else {
        if(c==0){
            cout <<"Preorder: "<< bt->data;
            c=1;
		}else{
		    cout <<" "<< bt->data;
		}
             //访问根结点bt的数据域
		PreOrder(bt->lchild);               //前序递归遍历bt的左子树
		PreOrder(bt->rchild);               //前序递归遍历bt的右子树
	}
}

template <class DataType>
BiNode<DataType> *BiTree<DataType> ::Creat(DataType *h,DataType *z,int n){
    if(n==0)
        return NULL;
    int k=0;
    while(h[n-1]!=z[k]){
        k++;
    }
    BiNode<DataType> *t=new BiNode<DataType>(h[n-1]);
    t->lchild=Creat(h,z,k);
    t->rchild=Creat(h+k,z+k+1,n-1-k);
    return t;

}
int main( )
{
	BiTree<int> asd;
    asd.PreOrder();
	return 0;
}
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/小丑西瓜9/article/detail/663503
推荐阅读
相关标签
  

闽ICP备14008679号