赞
踩
需求描述:
1.搭建有俩台核心交换机做热备份(网关冗余)的公司网络
2.在网络中实现VLAN的负载均衡
实现思路:
1:配置交换机基本信息 2:VRRP的基本配置 3:配置VRRP的优先级 4:配置VRRP的占先权
5:配置STP(MSTP)实现VLAN负载均衡 6:验证VRRP。
网络规划:
(1)交换机之间的接口全部为Trunk类型。
(2)在SW1和SW2上配置VRRP,Master路由器优先级为120,Backup路由器优先级为100.当Master路由器的上行接口出现故障,其优先级减少60,实现Master路由器到Backup路由器的切换。(3)在SW1交换机上配置VLAN接口IP地址:
VLAN2接口IP地址:192.103.2.1/24
VLAN3接口IP地址:192.103.3.1/24
VLAN4接口IP地址:192.103.4.1/24
(4)在SW2交换机上配置VLAN接口IP地址:
VLAN2接口IP地址:192.103.2.2/24
VLAN3接口IP地址:192.103.3.2/24
VLAN4接口IP地址: 192.103.4.2/24
(5)PC的IP地址及网关如下:
PC1的IP地址:192.103.2.10/24,网关为192.103.2.254/24
PC2的IP地址:192.103.3.10/24,网关为192.103.3.254/24
PC3的IP地址:192.103.2.11/24,网关为192.103.2.254/24
PC4的IP地址:192.103.4.10/24,网关为192.103.4.254/24
(6)SW1与NAT网段:100.103.1.0/30,SW2与NAT网段:100.103.1.4/30,NAT上用Loopback0模拟Internet,IP地址为200.103.1.1/24。
代码如下:
1. 首先,把PC1、PC2、PC3、PC4如同上图所配置,填写完网关后请点击应用设置按钮。其次开始配置交换机基本配置。
- /SW4的代码如下:
- sys
- un in en //关掉修改信息时间显示
- vlan batch 2 to 4 //创建vlan2、3、4
- interface Ethernet0/0/1 //进入交换机接口修改链路类型。access:用于终端设备(PC、服务器)
- port link-type access
- port default vlan 2
- interface Ethernet0/0/2
- port link-type access
- port default vlan 4
- interface Ethernet0/0/14
- port link-type trunk
- port trunk allow-pass vlan 2 to 4
- interface Ethernet0/0/15
- port link-type trunk //进入交换机接口改链路类型。Trunk:用于交换机之间的连接
- port trunk allow-pass vlan 2 to 4
- q
补充:链路类型有3种,分别是access,trunk,hybrid。他们的适用情况为access适用于终端设备,如PC、服务器等;trunk适用于交换机与交换机的连接;hybrid接口类型介于俩者之间连接。
- /SW3:
- sys
- sysname SW3
- undo info-center enable
- vlan batch 2 to 4
- interface Ethernet0/0/1
- port link-type access
- port default vlan 2
- interface Ethernet0/0/2
- port link-type access
- port default vlan 3
- interface Ethernet0/0/14
- port link-type trunk
- port trunk allow-pass vlan 2 to 4
- interface Ethernet0/0/15
- port link-type trunk
- port trunk allow-pass vlan 2 to 4
- q
- ///同理如上SW1///
- /SW2:
- sy
- sysname SW2
- undo info-center enable
- vlan batch 2 to 4 100
- interface GigabitEthernet0/0/1
- port link-type access
- port default vlan 100
- interface GigabitEthernet0/0/13
- port link-type trunk
- port trunk allow-pass vlan 2 to 4
- /SW1:
- sy
- sysname SW1
- undo info-center enable
- vlan batch 2 to 4 100
- interface GigabitEthernet0/0/1
- port link-type access
- port default vlan 100
- interface GigabitEthernet0/0/13
- port link-type trunk
- port trunk allow-pass vlan 2 to 4
- interface GigabitEthernet0/0/14
- port link-type trunk
- port trunk allow-pass vlan 2 to 4
- interface GigabitEthernet0/0/15
- port link-type trunk
- port trunk allow-pass vlan 2 to 4
- q
2:VRRP的基本配置 3:配置VRRP的优先级 4:配置VRRP的占先权
5:配置STP(MSTP)实现VLAN负载均衡:
根据实例设置,我们可以得到根交换机的结果,在实验过程中,被阻塞的接口可能与本实验有所不同,但被阻塞的链路是一样的,这就实现了链路同时启用,进行负载分担,同时又提供备用来应对故障的目标。6:验证VRRP。
- SW4:
- stp region-configuration
- region-name MSTP1
- instance 1 vlan 2
- instance 2 vlan 3 to 4
- active region-configuration
- q
- cluster enable
- ntdp enable
- //SW3:
- stp region-configuration
- region-name MSTP1
- instance 1 vlan 2
- instance 2 vlan 3 to 4
- active region-configuration
- q
- cluster enable
- ntdp enable
- ndp enable
- drop illegal-mac alarm
- /SW2:
- stp region-configuration
- region-name zy
- revision-level 1
- instance 1 vlan 2
- instance 2 vlan 3 to 4
- active region-configuration
- q
- stp instance 1 root secondary
- stp instance 2 root primary //设置为实例2跟交换机
- ospf 1 router-id 200.103.1.1
- area 0.0.0.0
- network 200.103.1.0 0.0.0.255
- network 100.103.1.2 0.0.0.0
- network 100.103.1.6 0.0.0.0
- q
- q
- interface Vlanif2
- ip address 192.103.2.2 255.255.255.0
- vrrp vrid 2 virtual-ip 192.103.2.254
- vrrp vrid 2 priority 100
- vrrp vrid 2 preempt-mode timer delay 1
- q
- interface Vlanif3
- ip address 192.103.3.2 255.255.255.0
- vrrp vrid 3 virtual-ip 192.103.3.254
- vrrp vrid 3 priority 120
- vrrp vrid 3 preempt-mode timer delay 1
- vrrp vrid 3 track interface GigabitEthernet0/0/1 reduced 60
- q
- interface Vlanif4
- ip address 192.103.4.2 255.255.255.0
- vrrp vrid 4 virtual-ip 192.103.4.254
- vrrp vrid 4 priority 120
- vrrp vrid 4 preempt-mode timer delay 1
- vrrp vrid 4 track interface GigabitEthernet0/0/1 reduced 60
- q
- interface Vlanif100
- ip address 100.103.1.5 255.255.255.252
- q
- //SW1:
- interface Vlanif2
- ip address 192.103.2.1 255.255.255.0
- vrrp vrid 2 virtual-ip 192.103.2.254
- vrrp vrid 2 priority 120
- vrrp vrid 2 preempt-mode timer delay 1
- vrrp vrid 2 track interface GigabitEthernet0/0/1 reduced 60
- q
- interface Vlanif3
- ip address 192.103.3.1 255.255.255.0
- vrrp vrid 3 virtual-ip 192.103.3.254
- vrrp vrid 3 priority 120
- vrrp vrid 3 preempt-mode timer delay 3
- vrrp vrid 3 timer advertise 3
- q
- interface Vlanif4
- ip address 192.103.4.1 255.255.255.0
- vrrp vrid 4 virtual-ip 192.103.4.254
- vrrp vrid 4 priority 100
- vrrp vrid 4 preempt-mode timer delay 1
- q
- interface Vlanif100
- ip address 100.103.1.1 255.255.255.252
- q
- stp region-configuration
- region-name MSTP1
- instance 1 vlan 2
- instance 2 vlan 3 to 4
- active region-configuration
- q
- ospf 1 router-id 200.103.1.1
- area 0.0.0.0
- network 200.103.1.0 0.0.0.255
- network 100.103.1.2 0.0.0.0
- network 100.103.1.6 0.0.0.0
- q
- q
- NAT:
- stp region-configuration
- region-name MSTP1
- instance 1 vlan 2
- instance 2 vlan 3 to 4
- active region-configuration
- q
- ip route-static 0.0.0.0 0.0.0.0 100.103.1.1
- ip route-static 0.0.0.0 0.0.0.0 100.103.1.5
- ospf 1 router-id 200.103.1.1
- area 0.0.0.0
- network 200.103.1.0 0.0.0.255
- network 100.103.1.2 0.0.0.0
- network 100.10.1.6 0.0.0.0
- q
- q
验证:
学习资料补充:
一:
(1)RSTP在STP基础上进行了改进,实现了网络拓扑快速收敛。但由于局域网内所有
的VLAN共享一棵生成树,因此被阻塞后链路将不承载任何流量,无法在VLAN间
实现数据流量的负载均衡,从而造成带宽浪费。
为了弥补STP和RSTP的缺陷,IEEE于2002年发布的802.1s标准定义了MSTP。
MSTP兼容STP和RSTP,既可以快速收敛,又提供了数据转发的多个冗余路径,在
数据转发过程中实现VLAN数据的负载均衡。
(2)几个概念:instance 1,实例 1,实例具有组概念,对应多个VLAN,一个实例对一棵生成树。 MST域: 多生成树区域。
MSTP的配置步骤:
(1)进入mst域视图; (2)设置MST域的域名; (3)设置MST实例域VLAN的映射关系; (4)(可选项)设置MST域的修订级别; (5)激活MST域。
二:什么是VRRP
1、VRRP含义 VRRP:Virtual Router Redundancy Protocol,虚拟路由器备份协议。 VRRP组成员:Master路由器,Backup路由器,虚拟路由器,其他路由器。
2、VRRP原理:虚拟路由冗余协议VRRP(Virtual Router Redundancy Protocol)是一种用于提高网络可靠性的容错协议。通过VRRP,可以在主机的下一跳设备出现故障时,及时将业务切换到备份设备,从而保障网络通信的连续性和可靠性。
3、VRRP基本描述:VRRP能够在不改变组网的情况下,将多台路由器虚拟成一个虚拟路由器,通过配置虚拟路由器的IP地址为默认网关,实现网关的备份。
4、配置命令 :
关键字: vrrp vrid id …… 配置步骤: (1)虚拟路由器 virtual-ip (2)优先级 priority (3)占先权 preempt-mode (4)时钟:(Hello间隔) timer (5)跟踪 track。
三:STP
(1)STP定义 STP:Spanning Tree Protocol,生成树协议。 STP作用:为解决交换网络中的环路问题,从逻辑上实现环变为树,避免出现环路。 引入STP目的:以太网交换网络中为了进行链路备份,提高网络可靠性,通常会使用冗余链路。但是使 用冗余链路会在交换网络上产生环路,引发广播风暴以及MAC地址表不稳定等故障现象,从而导致用户 通信质量较差,甚至通信中断。
(2)TP工作原理(算法步骤) STP操作(算法步骤): 1、选举一个根桥;(根桥,Root Bridge,RB) 2、每个非根交换机选举一个根端口;(根端口,Root Port,RP) 3、每个网段选举一个指定端口; (指定端口,Desi Port,DP) 4、阻塞非根、非指定端口。 (阻塞,Block,Discarding)
(3)STP算法步骤: 1、选举一个根桥; BID最小的交换机为根桥(RB)。 2、每个非根交换机选举一个根端口(RP); (1)到根桥的根路径开销(RPC)最小 (2)BID最小 (3)PID最小 3、每个网段选举一个指定端口(DP); 注意:根桥上的所有使用的端口都是指定端口。 (1)到根桥的根路径开销(RPC)最小 (2)BID最小 (3)PID最小 4、阻塞(Block)非根、非指定端口。
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。