赞
踩
小强在统计一个小区里居民的出生年月,但是发现大家填写的生日格式不统一,例如有的人写 199808,有的人只写 9808。有强迫症的小强请你写个程序,把所有人的出生年月都整理成 年年年年-月月 格式。对于那些只写了年份后两位的信息,我们默认小于 22 都是 20 开头的,其他都是 19 开头的。
输入格式:
输入在一行中给出一个出生年月,为一个 6 位或者 4 位数,题目保证是 1000 年 1 月到 2021 年 12 月之间的合法年月。
输出格式:
在一行中按标准格式 年年年年-月月 将输入的信息整理输出。
输入样例 1:
9808
结尾无空行
输出样例 1:
1998-08
结尾无空行
输入样例 2:
0510
结尾无空行
输出样例 2:
2005-10
结尾无空行
输入样例 3:
196711
结尾无空行
输出样例 3:
1967-11
结尾无空行
#include<stdio.h>
#include<string.h>
int main()
{
int yy,mm,dd,i,j;
char str[100];
scanf("%s",&str);
if(strlen(str)==4)
{
yy = (str[0]-'0')*10+(str[1]-'0');
if(yy<22)
{
printf("20%c%c-%c%c",str[0],str[1],str[2],str[3]);
}
else
{
printf("19%c%c-%c%c",str[0],str[1],str[2],str[3]);
}
}
else if(strlen(str)==6)
{
printf("%c%c%c%c-%c%c",str[0],str[1],str[2],str[3],str[4],str[5]);
}
return 0;
}
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。