当前位置:   article > 正文

Codeforces Educational Codeforces Round 105 A. ABC String c++_codeforces abcstring

codeforces abcstring

A. ABC String

You are given a string a, consisting of n characters, n is even. For each i from 1 to n ai is one of ‘A’, ‘B’ or ‘C’.

A bracket sequence is a string containing only characters “(” and “)”. A regular bracket sequence is a bracket sequence that can be transformed into a correct arithmetic expression by inserting characters “1” and “+” between the original characters of the sequence. For example, bracket sequences “()()” and “(())” are regular (the resulting expressions are: “(1)+(1)” and “((1+1)+1)”), and “)(”, “(” and “)” are not.

You want to find a string b that consists of n characters such that:

b is a regular bracket sequence;
if for some i and j (1≤i,j≤n) ai=aj, then bi=bj.
In other words, you want to replace all occurrences of ‘A’ with the same type of bracket, then all occurrences of ‘B’ with the same type of bracket and all occurrences of ‘C’ with the same type of bracket.

Your task is to determine if such a string b exists.

Input
The first line contains a single integer t (1≤t≤1000) — the number of testcases.

Then the descriptions of t testcases follow.

The only line of each testcase contains a string a. a consists only of uppercase letters ‘A’, ‘B’ and ‘C’. Let n be the length of a. It is guaranteed that n is even and 2≤n≤50.

Output
For each testcase print “YES” if there exists such a string b that:

b is a regular bracket sequence;
if for some i and j (1≤i,j≤n) ai=aj, then bi=bj.
Otherwise, print “NO”.

You may print every letter in any case you want (so, for example, the strings yEs, yes, Yes and YES are all recognized as positive answer).

输入样例
4
AABBAC
CACA
BBBBAC
ABCA

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
输出样例
YES
YES
NO
NO

  • 1
  • 2
  • 3
  • 4
  • 5

解题思路

这道题我的思路是先按照出现次数找到相应的A,B,C
然后按照首字母分为两种情况
然后就是找前i(1<i<size)个字母时候存在")“的数量是否大于”(",如果存在那么输出NO,结束
如果一直都可以运行,就输出YES

AC代码

#include <iostream>
#include <cstring>
using namespace std;
int A,B,C;
int main() {
   
	int n;
	cin>>n;
	getchar();
	while(n--) {
   
		int
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/我家自动化/article/detail/71588
推荐阅读
相关标签
  

闽ICP备14008679号