当前位置:   article > 正文

ZZULIOJ 1197: 考试排名(一)(结构体专题)_oj1197考试排名

oj1197考试排名

题目描述
今天浙大研究生复试的上机考试跟传统笔试的打分规则相似,总共有n道题,每道题有对应分值,最后计算总成绩。现给定录取分数线,请你写程序找出最后通过分数线的考生,并将他们的成绩按降序打印。

输入
第1行给出考生人数N ( 1<= N<=100 )、考题数M (1<=M<=10 )、分数线(正整数)G;
第2行排序给出第1题至第M题的正整数分值;
以下N行,每行给出一名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。

输出
首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考号的升序输出。

样例输入 Copy
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
样例输出 Copy
3
CS003 60
CS001 37
CS004 37

#include<iostream>
#include<algorithm>
using namespace std;
struct student
{
	string name;
	int num;
	int ex[11];
	int all;
}st[110];
bool cmp(const student &st1,const student &st2)
{
	if(st1.all!=st2.all)
	return st1.all>st2.all;
	else
	return st1.name.compare(st2.name)<0;
}
int main()
{
	int n,m,g;
	cin>>n>>m>>g;
	int f[11];
	for(int i=0;i<m;i++)
	cin>>f[i];
	int cnt=0;
	for(int i=0;i<n;i++)
	{
		cin>>st[i].name>>st[i].num;
		st[i].all=0;
		for(int j=0;j<st[i].num;j++)
		{
			cin>>st[i].ex[j];
			st[i].all+=f[st[i].ex[j]-1];
		}
		if(st[i].all>=g)
		cnt++;
	}
    cout<<cnt<<endl;
	
	sort(st,st+n,cmp);
	for(int i=0;i<n;i++)
	if(st[i].all>=g)
	cout<<st[i].name<<" "<<st[i].all<<endl;
	return 0;
} 
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/木道寻08/article/detail/884303
推荐阅读
相关标签
  

闽ICP备14008679号