当前位置:   article > 正文

洛谷 B3609 [图论与代数结构 701] 强连通分量 题解 tarjan算法

洛谷 B3609 [图论与代数结构 701] 强连通分量 题解 tarjan算法

[图论与代数结构 701] 强连通分量

题目描述

给定一张 n n n 个点 m m m 条边的有向图,求出其所有的强连通分量。

注意,本题可能存在重边和自环。

输入格式

第一行两个正整数 n n n m m m ,表示图的点数和边数。

接下来 m m m 行,每行两个正整数 u u u v v v 表示一条边。

输出格式

第一行一个整数表示这张图的强连通分量数目。

接下来每行输出一个强连通分量。第一行输出 1 号点所在强连通分量,第二行输出 2 号点所在强连通分量,若已被输出,则改为输出 3 号点所在强连通分量,以此类推。每个强连通分量按节点编号大小输出。

样例 #1

样例输入 #1

6 8
1 2
1 5
2 6
5 6
6 1
5 3
6 4
3 4
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9

样例输出 #1

3
1 2 5 6
3
4
  • 1
  • 2
  • 3
  • 4

提示

对于所有数据, 1 ≤ n ≤ 10000 1 \le n \le 10000 1n10000 1 ≤ m ≤ 100000 1 \le m \le 100000 1m100000

原题

洛谷B3609——传送门

代码

#include <bits/stdc++.h>
using namespace std;
using i64 = long long;
typedef long long ll;

const int MAX = 1e5 + 6;
vector<int> e[MAX];
int dfn[MAX]; // 时间戳:dfn[i]表示节点i第一次被访问的顺序
int low[MAX]; // 追溯值:low[i]表示从节点i出发所能访问到的最早时间戳
int tot;        // 时间戳编号
int sta[MAX];   // 栈
int insta[MAX]; // 是否在栈中
int top;        // 栈顶索引
int scc[MAX];   // 强连通分量编号
int siz[MAX];   // 强连通分量大小
int cnt;        // 第cnt个强连通分量

vector<int> scc_num[MAX]; // 每个强连通分量里的元素
int vis[MAX];             // 第i个节点所在强连通分量是否已经输出

void scc_tarjan(int x)
{
    // 进入x时,盖戳,入栈
    dfn[x] = low[x] = ++tot;
    sta[++top] = x;
    insta[x] = 1;
    for (int y : e[x])
    {
        if (!dfn[y]) // y尚未访问
        {
            scc_tarjan(y);
            low[x] = min(low[x], low[y]); // 回到x时更新low
        }
        else if (insta[y]) // 如果y已访问且在栈中
        {
            low[x] = min(low[x], dfn[y]); // 回到x时更新low
        }
    }
    // 离开x时,记录SCC
    if (dfn[x] == low[x]) // 如果x是所处SCC的根
    {
        int y;
        ++cnt;
        do
        {
            y = sta[top--];
            insta[y] = 0;
            scc[y] = cnt;
            scc_num[cnt].push_back(y);
            ++siz[cnt];
        } while (y != x);
    }
}

int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);

    int n, m;
    cin >> n >> m;
    int a, b;
    for (int i = 1; i <= m; i++)
    {
        cin >> a >> b;
        e[a].push_back(b);
    }
    for (int i = 1; i <= n; i++) //图可能不连通,所以需遍历所有节点
    {
        if (!dfn[i])
            scc_tarjan(i);
    }
    cout << cnt << '\n';
    for (int i = 1; i <= n; i++)
    {
        if (!vis[i])
        {
            sort(scc_num[scc[i]].begin(), scc_num[scc[i]].end()); //需按节点编号大小输出
            for (int j = 0; j < scc_num[scc[i]].size(); j++)
            {
                cout << scc_num[scc[i]][j] << " \n"[j == scc_num[scc[i]].size() - 1];
                vis[scc_num[scc[i]][j]] = 1; //标记已输出该节点
            }
        }
    }

    return 0;
}
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
  • 84
  • 85
  • 86
  • 87
  • 88
声明:本文内容由网友自发贡献,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:【wpsshop博客】
推荐阅读
相关标签
  

闽ICP备14008679号