赞
踩
题目描述
会下国际象棋的人都很清楚:皇后可以在横、竖、斜线上不限步数地吃掉其他棋子。如何将8个皇后放在棋盘上(有8 * 8个方格),使它们谁也不能被吃掉!这就是著名的八皇后问题。
输入
一个整数n( 1 < = n < = 10 )
输出
每行输出对应一种方案,按字典序输出所有方案。每种方案顺序输出皇后所在的列号,相邻两数之间用空格隔开。如果一组可行方案都没有,输出“no solute!”
样例输入 Copy
4
样例输出 Copy
2 4 1 3 3 1 4 2
- #include <iostream>
- #include <cstdio>
- #include <algorithm>
- using namespace std;
- int n,a[20],ans,cnt,b[800][20];
- void dfs(int deep)
- {
- if(deep==n+1){
- ans++;
- for(int i=1;i<=n;i++) b[cnt][i]=a[i];
- cnt++;
- return;
- }
- for(int i=1;i<=n;i++){
- bool flag=true;///判断当前位置是否合法
- for(int j=1;j<deep;j++){
- if(a[j]==i||(deep-j)==abs(i-a[j])){
- flag=false;
- break;
- }
- }
- if(flag){//如果当先位置合法,则递归搜索下一个合法位置
- a[deep]=i;
- dfs(deep+1);
- }
- }
- return;
- }
- int main()
- {
- while(scanf("%d",&n)!=EOF){
- cnt=0;
- ans=0;
- dfs(1);
- if(ans==0) printf("no solute!\n");
- else{
- for(int i=0;i<cnt;i++){
- for(int j=1;j<=n;j++){
- printf("%d ",b[i][j]);
- }
- printf("\n");
- }
- }
- }
- return 0;
- }
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。