当前位置:   article > 正文

浙大版《C语言程序设计(第3版)》题目集

浙大版《C语言程序设计(第3版)》题目集

练习5-2 找两个数中最大者

本题要求对两个整数a和b,输出其中较大的数。

函数接口定义:

int max( int a, int b );

其中ab是用户传入的参数,函数返回的是两者中较大的数。

裁判测试程序样例:

#include <stdio.h>

int max( int a, int b );

int main() {

int a, b;

scanf("%d %d", &a, &b);

printf("max = %d\n", max(a, b));

return 0; }

/* 你的代码将被嵌在这里 */

输入样例:

-5 8

输出样例:

max = 8

 

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int max(int a,int b);
 
int main(int argc, char *argv[]) {
    int a,b;
    scanf("%d %d",&a,&b);
    printf("max = %d\n",max(a,b));
    return 0;
}

int max(int a,int b){
    if(a>b){
        return a;
    }
    return b;
}

声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/煮酒与君饮/article/detail/970316
推荐阅读
相关标签
  

闽ICP备14008679号