当前位置:   article > 正文

002_OJ题目通用知识点_简单_1589 HZF的魔法棒_有一个包含大小写字母和数字的字符串,身为小小程序设计师的你拥有两项魔法,一项魔

有一个包含大小写字母和数字的字符串,身为小小程序设计师的你拥有两项魔法,一项魔

题目描述

HZF有一个魔法棒,魔法棒有很多功能,其中最简单的是对字母的改变:可以将大写字母变成小写字母(A->a,B->b,C->c…Z->z),将小写字母变成大写字母(a->A…z->Z),魔法对数字不生效。HZF让你告诉他改变之后的字符串是什么样的。

解答要求

时间限制:1000ms, 内存限制:256MB

输入

输入一个字符串(只包含大小写字母和数字)。每个字符串字符数(0 < n <= 1000)。

输出

输出改变后的字符串。

样例

输入样例 1

abC02

输出样例 1

ABc02

输入样例 2

aceACE

输出样例 2

ACEace

Python实现代码

代码1

# If you need to import additional packages or classes, please import here.
'''
    19.5ms
    7MB
'''
def func():
    # please define the python3 input here. For example: a,b = map(int, input().strip().split())
    # please finish the function body here. 
    # please define the python3 output here. For example: print().

    input_str = input().strip()
    result_list = []
    for item_str in input_str:
        if 'a' <= item_str <= 'z':
            result_list.append(item_str.upper())
        elif 'A' <= item_str <= 'Z':
            result_list.append(item_str.lower())
        else:
            result_list.append(item_str)
    print("".join(result_list))  # 将列表转换为字符串


if __name__ == "__main__":
    func()
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24

代码2

# If you need to import additional packages or classes, please import here.
'''
    17ms
'''
def func():
    # please define the python3 input here. For example: a,b = map(int, input().strip().split())
    # please finish the function body here. 
    # please define the python3 output here. For example: print().

    str1 = input()
    list1 = list()
    for i in str1:
        if i.islower():
            list1.append(i.upper())
        elif i.isupper():
            list1.append(i.lower())
        else:
            list1.append(i)
    print("".join(list1))


if __name__ == "__main__":
    func()
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/秋刀鱼在做梦/article/detail/1013536
推荐阅读
相关标签
  

闽ICP备14008679号