当前位置:   article > 正文

数字反转(C/C++)_c++实现数字反转

c++实现数字反转

给定一个整数,请将该数各个位上数字反转得到一个新数。新数也应满足整数的常见形式,即除非给定的原数为零,否则反转后得到的新数的最高位数字不应为零(参见样例 2)。

输入格式
输入共 1 行,一个整数 N。

输出格式
输出共 1 行,一个整数,表示反转后的新数。

数据范围
−1,000,000,000≤N≤1,000,000,000。

Sample Input
123
Sample Output
321
Sample Input 2
-380
Sample Output 2
-83

这题我们直接用字符串做更简单,详细看代码

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cstdlib>
#include <algorithm>
#include<string.h>
#include<queue> 
#include<math.h>
#include<set>
#define llu unsigned long long
using namespace std;

int main()
{
	int f=0;//f=1代表数为负数 ,f=0代表正数 
	string s;
	cin >> s;
	
	//特判两种情况 
	if(s=="0"){
		cout << "0" << endl ;
		return 0;
	}
	else if(s=="-0"){
		cout << "-0" << endl ;
		return 0;
	}
	
	
	if(s[0]=='-')f=1;
	int n=s.size();
	int k=n-1;//k来保存倒序第一个不为0的数字的位置; 

	while(s[k]=='0')
		k--;//看看从哪一位开始倒序输出 
	if(f)cout << "-" ;
	for(int i=k;i>=f;i--)
		cout << s[i] ;
	
	return 0;
}




  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/程序自动化专家/article/detail/60512
推荐阅读
相关标签
  

闽ICP备14008679号