赞
踩
时间限制
100 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue
输入两个非负10进制整数A和B(<=230-1),输出A+B的D (1 < D <= 10)进制数。
输入格式:
输入在一行中依次给出3个整数A、B和D。
输出格式:
输出A+B的D进制数。
输入样例:
123 456 8
输出样例:
1103
//第一种:
//itoa经过试验,无论怎么改都不能在oj平台通过,code,vc上都不能通过
#include<iostream>
using namespace std;
int main()
{
int a;
int b,n;
cin >> a >> b;
int c = a + b;
char num[1000000];
cin >> n;
_itoa(c,num,n);
cout << num;
return 0;
}
//第二种
#include<iostream>
#include<vector>
using namespace std;
int main()
{
long a, b, c;
cin >> a >> b >> c;
long d = a + b;
vector<int> num;
if (d == 0)
{
cout << 0;
return 0;
}
while (d>0)
{
int k = d % c;
num.push_back(k);
d /= c;
}
for (int j = num.size() - 1; j >= 0; j--)
{
cout << num[j];
}
}
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。