Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.
Input Specification: Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.
Output Specification: For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:
81---0-27----5-46
1
2
3
4
5
6
7
8
9
Sample Output:
415
1
代码展示
本题的思路就是首先生成一棵二叉树,然后对树进行层次遍历,并且在过程中打印叶子节点的信息
tips:在建树时,若入口参数设为数组引用,那么就可以通过DEBUG来观察目前树中的所有元素 tree buildTree (treeNode (&T)[MAXSIZE])
#include<iostream>#include<deque>#defineMAXSIZE10#defineNull-1#definetreeintstructtreeNode{int data;int left;int right;}T[MAXSIZE];
tree buildTree(treeNode(&T)[MAXSIZE]){int n;int root =-1;
std::cin >> n;int isroot[MAXSIZE]={0};if(n ==1){
T[0].data =0;
T[0].left = Null;
T[0].right = Null;return0;}for(int i =0; i < n; i++){char l, r;
std::cin >> l >> r;
T[i].data = i;if(l !='-'){
T[i].left = l -'0';
isroot[T[i].left]=1;}else T[i].left = Null;if(r !='-'){
T[i].right = r -'0';
isroot[T[r].right]=1;}else T[i].right = Null;if(l =='-'&& r =='-'){
isroot[i]=1;}}for(int i =0; i < n; i++){if(!isroot[i]){
root = i;return root;}}return root;}/*
使用队列:根节点入队,
循环开始:节点出队,访问节点,并将其左右子节点入队
*/voidlevelOrderTraversal(tree root){int flag =0;
tree r = root;
tree cur;
std::deque<tree> deque;//队列只用存储节点的编号
deque.push_back(T[r].data);//根节点入队while(!deque.empty()){//出队
cur = deque.front();
deque.pop_front();//访问出队节点中的叶子结点if(T[cur].left == Null && T[cur].right == Null){if(flag ==0){
std::cout << cur;
flag =1;}else std::cout <<' '<< cur;}//将其左右子节点入队if(T[cur].left != Null){
deque.push_back(T[cur].left);}if(T[cur].right != Null){
deque.push_back(T[cur].right);}}}intmain(){
tree r;
r =buildTree(T);//r为根节点levelOrderTraversal(r);return0;}