当前位置:   article > 正文

基础练习 | 十六进制转十进制(java实现)_编写一个实现16进制字符串转换成10进制字符串静态方法,方法头如下: public static

编写一个实现16进制字符串转换成10进制字符串静态方法,方法头如下: public static

问题描述
  从键盘输入一个不超过8位的正的十六进制数字符串,将它转换为正的十进制数后输出。
  注:十六进制数中的10~15分别用大写的英文字母A、B、C、D、E、F表示。

样例输入
FFFF

样例输出
65535
  • 1
  • 2
  • 3
  • 4
  • 5
import java.util.Scanner;
public class 十六进制转十进制 {
	public static void main(String[] args) {
		long result = 0;
		Scanner sc = new Scanner(System.in);
		String str = sc.nextLine();
		for(int i=0;i<str.length();i++){
			int length = str.length()-i-1;
			char str2 = str.charAt(i);
			if((int)str2-48>9){
				if(str2=='A')
					result += 10*Math.pow(16,length);
				else if(str2=='B')
					result += 11*Math.pow(16,length);
				else if(str2=='C')
					result += 12*Math.pow(16,length);
				else if(str2=='D')
					result += 13*Math.pow(16,length);
				else if(str2=='E')
					result += 14*Math.pow(16,length);
				else if(str2=='F')
					result += 15*Math.pow(16,length);
			}else{
				int num = (int)str2-48;
				result += num*Math.pow(16,length);
			}
		}
		System.out.println(result);

	}
}

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/羊村懒王/article/detail/244474
推荐阅读
相关标签
  

闽ICP备14008679号