赞
踩
7-1 藏头诗
本题要求编写一个解密藏头诗的程序。
输入格式:
输入为一首中文藏头诗,一共四句,每句一行。注意:一个汉字占三个字节。
输出格式:
取出每句的第一个汉字并连接在一起形成一个字符串并输出。同时在末尾输入一个换行符。
输入样例:
一叶轻舟向东流
帆稍轻握杨柳手
风纤碧波微起舞
顺水任从雅客流
输出样例:
一帆风顺
C语言
- #include <stdio.h>
- #define N 4
-
- int main()
- {
- char a[4][20];
- int i;
-
- for (i = 0; i < N; i++)
- scanf("%s", a[i]);
- for (i = 0; i < N; i++)
- printf("%c%c", a[i][0], a[i][1], a[i][2]); //一个char是一个字节,而一个汉字占三个字节,所以要输出每一行数组的前两个才是一个汉字。
- printf("\n");
-
- return 0;
- }
c++
- #include <iostream>
- #include<cstring>
- using namespace std;
- int main()
- {
- char a[100];
- for(int i=1;i<=4;i++)
- {
- cin>>a;
- cout<<a[0]<<a[1]<<a[2];
- }
- return 0;
- }
c++
- #include <stdio.h>
- #include <iostream>
- #include <string>
- using namespace std;
- void coutf(char a[]) {
- for (int i = 0; i < 3; i++)
- {
- cout << a[i];
- }
- }
- int main()
- {
- char a[1000], b[1000], c[1000], d[1000], e[1000];
- cin >> a >> b >> c >> d;
- coutf(a);
- coutf(b);
- coutf(c);
- coutf(d);
- cout << endl;
- return 0;
- }
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。