当前位置:   article > 正文

L1-8 估值一亿的AI核心代码 (20分)_本题要求你实现一个稍微更值钱一点的 ai 英文问答程序,规则是: 无论用户说什么,首

本题要求你实现一个稍微更值钱一点的 ai 英文问答程序,规则是: 无论用户说什么,首

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you;
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。
输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。
输入样例:

6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don’t know

#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<sstream>
#include<string.h>
using namespace std;
const int maxn = 10010;
const int N = 11;
int main()
{
   
	string a[N];
	int n; cin >> n;
	getchar();
	for (int i = 1; i <= n; i++)getline(cin, a[i]);
	for (int i = 1; i <= n; i++)
	{
   
		string temp = a[i];
		cout << temp << endl;
		cout << "AI:";
		for (int j = 0; j < temp.size(); j++)
		{
   
			if (isalnum(temp[j]))
			{
   
				if (temp[j] != 'I')
					temp[j] = tolower(temp[j]);
			}
			else
			{
   
				temp.insert(j, " ");
				j++;
			}
			if (temp[j] == '?')
				temp[j] = '!';
		}
		stringstream ss(temp);
		string mid;
		string str[1005]; int idex = 1;
		while (ss >> mid)
		{
   
			str[idex++] = mid;
		}
		if (!isalnum(str[1][0]))	//如果第一个是其他字符,也需要空一格 
			cout << " ";

		for (
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/羊村懒王/article/detail/445998
推荐阅读
相关标签
  

闽ICP备14008679号