当前位置:   article > 正文

A - Subsequence (二分+前缀和)_前缀和 二分

前缀和 二分

A - Subsequence
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

前缀和
一维前缀和
这个优化主要是用来在O(1)时间内求出一个序列a中,a[i]+a[i+1]+……+a[j]的和。
具体原理十分简单:用sum[i]表示(a[1]+a[2]+……+a[i]),其中sum[0]=0,则(a[i]+a[i+1]+……+a[j])即等于sum[j]-sum[i-1]。
定义二维数组可用来计算一块矩形的面积。起到降维的作用

二分:
两个函数
lower_bound(start,end,num)
start,end是一个左闭右开的区间,返回值为大于等于num的第一个数的位置。
也可以类似于sort函数的那种用法
upper_bound 函数与上面函数不同点只有,该函数返回值为大于num的第一个数的位置。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define INF 1e6
int a[100000+5];
int sum[100000+5];
int main()
{
    int t,n,s,i,minn,ans=INF;
    cin>>t;
    while(t--)
    {
        cin>>n>>s;
        ans=INF;
        memset(sum,0,sizeof(sum));
        cin>>a[0];
        sum[0]=a[0];
        for(i=1;i<n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=a[i]+sum[i-1];
        }
        if(sum[n-1]<s)
        {
            cout<<"0"<<endl;
            continue;

        }

        for(i=0;s+sum[i]<=sum[n-1];i++)
        {
            minn=lower_bound(sum,sum+n,s+sum[i])-sum;

            ans=min(ans,minn-i);
        }
        cout<<ans<<endl;



    }
    return 0;
}
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/羊村懒王/article/detail/620871
推荐阅读
相关标签
  

闽ICP备14008679号