当前位置:   article > 正文

PAT-A1044题解_pat a1044

pat a1044

1044 Shopping in Mars (25 分)
Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10
​5
​​ ), the total number of diamonds on the chain, and M (≤10
​8
​​ ), the amount that the customer has to pay. Then the next line contains N positive numbers D
​1
​​ ⋯D
​N
​​ (D
​i
​​ ≤10
​3
​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5


题目大意:给你n个数字,然后给定一个数值m,找出数字片段之和等于m的索引区间。
如果没有的话,就找出大于m的最接近的值的索引区间。


总体来说难度不大,关键点在于时间复杂度,如果使用一般的查询的话,时间复杂度会在O(n^2),而如果通过对数据的预处理在加上二分查找的话,可以使时间复杂度降低至O(o-n*logn),这样就可以符合题目的运行时间要求,就不会超时了。

–*-
AC code

#include<cstdio>
#include<iostream>
using namespace std;
const int maxn=100010;
int d[maxn];
int binary(int L,int R,int x){   //查找索引
	int left=L,right=R,mid;
	while(left<right){
		mid=(left+right)/2;
		if(d[mid]>x){
			right=mid;
		}
		else{
			left=mid+1;
		}
	}
	return left;
}
int main(){
	int n,m,near;
	scanf("%d %d",&n,&m);
	d[0]=0;
	for(int i=1;i<=n;i++){
		int temp;
		scanf("%d",&temp);
		d[i]=d[i-1]+temp;
	}
	for(int i=1;i<=n;i++){
		int j=binary(i,n+1,d[i-1]+m);
		if(d[j-1]-d[i-1]==m){   //最接近的值就是m 
			near=m;      
			break;
		}
		else if(j<=n){ //大于m的最接近值 
			near=d[j]-d[i-1]; 
		}
	}
	for(int i=1;i<=n;i++){
		int j=binary(i,n+1,d[i-1]+near);
		if(d[j-1]-d[i-1]==near)
			printf("%d-%d\n",i,j-1);
	}
	return 0;
} 
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/羊村懒王/article/detail/645536
推荐阅读
相关标签
  

闽ICP备14008679号