赞
踩
视频来源:B站《乾颐堂HCIP-HCIE-security安全 2019年录制》
一边学习一边整理老师的课程内容及试验笔记,并与大家分享,侵权即删,谢谢支持!
附上汇总贴:华为防火墙基础自学系列 | 汇总_COCOgsta的博客-CSDN博客
A security association, more commonly referred to as an SA, is a basic building block of IPSec. An SA is an entry in the SA database (SADB) , which contains information about the security that has been negotiated between two parties for IKE or IPSec. There are two types of SAs:(SA是IPSec的一个基本组成部分,SA是SADB的一个条目, 它包含双方关于IKE和IPSec已经协商完毕的安全信息)
Although it is common practice to use the term SA to encompass both types, it is important to make the distinction for troubleshooting purposes, because each type of SA achieves a different purpose. Both SA types are established between IPSec peers using the IKE protocol.(两种类型的SA都由IKE协议协商产生)
IKE负责建立和维护IKE SAs和IPSec SAs。功能主要体现在如下几个方面:
IKEv1建立IKE SA的过程定义了主模式(Main Mode)和野蛮模式(Aggressive Mode)两种交换模式。
主模式包含三次双向交换,用到了六条信息。
野蛮模式只用到三条信息。
快速模式中,双方需要协商生成IPSec SA各项参数(包含可选参数PFS),并为IPSec SA生成认证/加密密钥。这在快速模式交换的前两条消息1和2中完成。消息3为确认信息,用于确认发送方收到该阶段的消息2,验证响应者是否可以通信。
Defined in RFC 4306 - updated by RFC 5996
Both are using the same basic structure aiming at:
Both run over UDP 500/4500
The first exchange, IKE_SA_INIT, is used to negotiate the security parameters(协商安全参数)by sending IKEv2 proposals, including the configured encryption and integrity protocols, DH values, and nonces (random) numbers(配置的加密和完整性校验协议,DH公共值和随机数). At this point, the two peers generate SKEYSEED (a seed security key value) from which all future IKE keys are generated. The messages that follow in later exchanges are encrypted and authenticated(后续的信息被加密和验证)using keys also generated from the SKEYSEED value.
发起方提供基本的SA(安全关联)参数和密钥交换材料。(等同于IKEv1的MM1和MM3两个包)
接收方发回一个可以接受的参数,并附带密钥交换内容和证书请求(可选项)。(等同于IKEv1的MM2和MM4)
The second exchange, IKE_AUTH, operates over the IKE_SA created by the IKE_SA_INIT(操作在由IKE_SA_INIT所创建的IKE_SA之上)exchanges and is used to validate the identity of the peers and negotiate the various encryption, authentication, and integrity protocols to establish the first CHILD_SA(协商各种加密,验证和完整性校验协议,用于建立第一个CHILD_SA)for use by ESP or AH in which IPsec communication occurs. Peers are validated using pre-shared keys, certificates, or Extensible Authentication Protocol (EAP) (allowing for legacy authentication methods between peers).
创建child SA相关的认证内容和参数(等同于IKEv1的MM5和部分QM)
创建于child SA相关的认证内容和参数(等同于MM6和部分QM)
身份认证
身份保护
DH(Diffie-Hellman)密钥交换算法
完善的前向安全性PFS(Perfect Forward Secrecy)
确认通信双方的身份(对等体的IP地址或名称),包括:
SW1
- vlan batch 10 16 20 40
- interface Ethernet0/0/4
- description Link_FW1_G0/0/0
- port link-type access
- port default vlan 16
- interface Ethernet0/0/8
- description Link_FW2_G0/0/0
- port link-type access
- port default vlan 16
- interface Ethernet0/0/21
- description Link_HCNP_MGMT
- port link-type access
- port default vlan 16
- interface Ethernet0/0/1
- description Link_FW1_G0/0/1
- port link-type access
- port default vlan 10
- interface Ethernet0/0/9
- description Link_HCNP_Dot1x(PC1)
- port link-type access
- port default vlan 10
- interface Ethernet0/0/5
- description Link_FW2_G0/0/1
- port link-type access
- port default vlan 20
- interface Ethernet0/0/24
- description Link_HCNP_VPN_Client(PC2)
- port link-type access
- port default vlan 20
- interface Ethernet0/0/2
- description Link_FW1_G0/0/2
- port link-type access
- port default vlan 40
- interface Ethernet0/0/23
- description Link_HCNP_Untrust
- port link-type access
- port default vlan 40
- interface Ethernet0/0/6
- description Link_FW2_G0/0/2
- port link-type access
- port default vlan 40
- 复制代码
FW1
- interface g0/0/1
- ip address 10.1.1.10 24
- interface g0/0/2
- ip address 202.100.1.10 24
- firewall zone untrust
- add int g0/0/2
- firewall zone trust
- add int g0/0/1
- ip route-static 0.0.0.0 0.0.0.0 202.100.1.11
- interface g0/0/0
- ip address 192.168.0.10 24
- // 图形化配置结果
- acl number 3000
- rule 5 permit ip source 10.1.1.0 0.0.0.255 destination 10.1.2.0 0.0.0.255
- ike proposal 1
- authentication-algorithm sha2-256
- integrity-algorithm aes-xcbc-96 hmac-sha2-256
- ike peer ike108112531427
- exchange-mode auto
- pre-shared-key Huawei@123
- ike-proposal 1
- undo version 1
- remote-id-type none
- remote-address 202.100.1.1
- ipsec proposal prop10811253142
- esp authentication-algorithm sha2-256
- ipsec policy ipsec1081125314 1 isakmp
- security acl 3000
- ike-peer ike108112531427
- alias ipsec_policy
- proposal prop10811253142
- local-address applied-interface
- sa duration traffic-based 200000000
- sa duration time-based 3600
- interface GigabitEthernet0/0/2
- ipsec policy ipsec1081125314 auto-neg
- 复制代码
FW2
- interface g0/0/1
- ip address 10.1.2.10 24
- interface g0/0/2
- ip address 202.100.1.11 24
- service-manage ping permit
- firewall zone untrust
- add int g0/0/2
- firewall zone trust
- add int g0/0/1
- interface g0/0/0
- ip address 192.168.0.11 24
- ip route-static 0.0.0.0 0.0.0.0 202.100.1.10
- 复制代码
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。