7-10 社交网络图中结点的“重要性”计算(30 point(s))
在社交网络中,个人或单位(结点)之间通过某些关系(边)联系起来。他们受到这些关系的影响,这种影响可以理解为网络中相互连接的结点之间蔓延的一种相互作用,可以增强也可以减弱。而结点根据其所处的位置不同,其在网络中体现的重要性也不尽相同。
“紧密度中心性”是用来衡量一个结点到达其它结点的“快慢”的指标,即一个有较高中心性的结点比有较低中心性的结点能够更快地(平均意义下)到达网络中的其它结点,因而在该网络的传播过程中有更重要的价值。在有N个结点的网络中,结点vi的“紧密度中心性”Cc(vi)数学上定义为vi到其余所有结点vj (j≠i) 的最短距离d(vi,vj)的平均值的倒数:
对于非连通图,所有结点的紧密度中心性都是0。
给定一个无权的无向图以及其中的一组结点,计算这组结点中每个结点的紧密度中心性。
输入格式:
输入第一行给出两个正整数N和M,其中N(≤104)是图中结点个数,顺便假设结点从1到N编号;M(≤105)是边的条数。随后的M行中,每行给出一条边的信息,即该边连接的两个结点编号,中间用空格分隔。最后一行给出需要计算紧密度中心性的这组结点的个数K(≤100)以及K个结点编号,用空格分隔。
输出格式:
按照Cc(i)=x.xx的格式输出K个给定结点的紧密度中心性,每个输出占一行,结果保留到小数点后2位。
输入样例:
9 14
1 2
1 3
1 4
2 3
3 4
4 5
4 6
5 6
5 7
5 8
6 7
6 8
7 8
7 9
3 3 4 9
输出样例:
Cc(3)=0.47
Cc(4)=0.62
Cc(9)=0.35
思路
我们先把所有的边 先用并查集 并进去 再查找 判断一下 是不是连通图
如果不是 对于每个点的询问 直接输出 0.00 就可以了
然后 如果是 连通图的话
我们就从 那个点开始
BFS
对于每层 访问到的点 都权值 都加上 当前层数 就是这个点 到中心点的距离
AC代码
- #include <cstdio>
- #include <cstring>
- #include <ctype.h>
- #include <cstdlib>
- #include <cmath>
- #include <climits>
- #include <ctime>
- #include <iostream>
- #include <algorithm>
- #include <deque>
- #include <vector>
- #include <queue>
- #include <string>
- #include <map>
- #include <stack>
- #include <set>
- #include <numeric>
- #include <sstream>
- #include <iomanip>
- #include <limits>
-
- #define CLR(a) memset(a, 0, sizeof(a))
- #define pb push_back
-
- using namespace std;
- typedef long long ll;
- typedef long double ld;
- typedef unsigned long long ull;
- typedef pair <int, int> pii;
- typedef pair <ll, ll> pll;
- typedef pair<string, int> psi;
- typedef pair<string, string> pss;
-
- const double PI = 3.14159265358979323846264338327;
- const double E = exp(1);
- const double eps = 1e-30;
-
- const int INF = 0x3f3f3f3f;
- const int maxn = 1e4 + 5;
- const int MOD = 1e9 + 7;
-
- vector <int> G[maxn];
-
- int pre[maxn];
-
- int find(int x)
- {
- while (x != pre[x])
- x = pre[x];
- return x;
- }
-
- void join(int x, int y)
- {
- int fx = find(x), fy = find(y);
- if (x != fy)
- pre[fx] = fy;
- }
-
- queue <int> q;
-
- int v[maxn];
-
- int tot;
-
- void bfs(int cur)
- {
- int len = q.size();
- for (int i = 0; i < len; i++)
- {
- int num = q.front();
- q.pop();
- vector <int>::iterator it;
- for (it = G[num].begin(); it != G[num].end(); it++)
- {
- if (v[(*it)] == 0)
- {
- q.push(*it);
- tot += cur;
- v[(*it)] = 1;
- }
- }
- }
- if (q.size())
- bfs(cur + 1);
- }
-
- void init()
- {
- for (int i = 0; i < maxn; i++)
- pre[i] = i;
- }
-
- int main()
- {
- init();
- int n, m;
- scanf("%d%d", &n, &m);
- int x, y;
- for (int i = 0; i < m; i++)
- {
- scanf("%d%d", &x, &y);
- G[x].pb(y);
- G[y].pb(x);
- join(x, y);
- }
- int flag = 1;
- int vis = find(1);
- for (int i = 2; i <= n; i++)
- {
- if (find(i) != vis)
- {
- flag = 0;
- break;
- }
- }
- if (flag == 0)
- {
- int k, num;
- scanf("%d", &k);
- for (int i = 0; i < k; i++)
- {
- scanf("%d", &num);
- printf("Cc(%d)=0.00\n", num);
- }
- }
- else
- {
- int k, num;
- scanf("%d", &k);
- for (int i = 0; i < k; i++)
- {
- scanf("%d", &num);
- CLR(v);
- while (!q.empty())
- q.pop();
- q.push(num);
- v[num] = 1;
- tot = 0;
- bfs(1);
- double ans = (n - 1) * 1.0 / tot;
- printf("Cc(%d)=%.2lf\n", num, ans);
- }
- }
- }
-
-
-
-
-
-