当前位置:   article > 正文

c 语言 查找最大元素_#include int findlongest( char str[] );in

#include int findlongest( char str[] );int main(){ char sarr[100] =

/*****
题目描述
对于输入的字符串,查找其中的ASCII码值最大字母,在该字母后面插入字符串“(max)”。
输入
输入一行长度不超过200的字符串组成,字符串仅由大小写字母构成。
输出
输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
样例输入 Copy
abcdefgfedcbag
样例输出 Copy
abcdefg(max)fedcbag(max)
*****/
!!!!!本文主要思路来源于[青梅煮茶] (https://blog.csdn.net/zzuli_acmer/article/details/78626541)

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    char str[1000];
    gets(str);char max;max = str[0];
    int i;
    for (i = 0 ;str[i] != '\0';i++)
    {
        if (str[i] > max)
        max = str[i];
    }
    for (i = 0 ;str[i] != '\0' ;i++)
    {
        if(str[i] == max)
        printf("%c(max)",str[i]);
        else
        printf("%c",str[i]);
    }
    return 0;
}

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
声明:本文内容由网友自发贡献,不代表【wpsshop博客】立场,版权归原作者所有,本站不承担相应法律责任。如您发现有侵权的内容,请联系我们。转载请注明出处:https://www.wpsshop.cn/w/我家自动化/article/detail/310096
推荐阅读
相关标签
  

闽ICP备14008679号