7-10 树的遍历(25 分)
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
- 7
- 2 3 1 5 7 6 4
- 1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
- #include<stdio.h>
- #include<string.h>
- #include<queue>
- #include<stdlib.h>
- #include<iostream>
- using namespace std;
- int btree[100]={0};//用于承装后续遍历的数字
- int ctree[100]={0};//用于承装中序遍历的数据
- struct node
- {
- node *l;
- node *r;
- int data;
- };
-
- int num=0;
- int n;
- node *creattree(int btree[],int ctree[],int n)//反向推算创建二叉树,注意这是指针
- {
- if(n<=0) return NULL;
- node *T=new node();
- int root=btree[n-1];//找到根节点
- int k;
- T->data=root;//创建树的节点
- for(int i=0;i<n;i++)//由于中序遍历使两边分开
- {
- if(ctree[i]==root)
- {
- k=i;
- break;
- }
- }
- T->l=creattree(btree,ctree,k);//左子树
- T->r=creattree(btree+k,ctree+k+1,n-(k+1));//右子树
- return T;
- }
- void print(node *T)//层次遍历输出二叉树
- {
- node *p;//为中间变量
- node *pr[100];
- int rear=-1,front=-1;
- rear++;
- pr[rear]=T;//将根节点放入到队列之中
- while(rear!=front)
- {
- front++;
- p=pr[front];//用来读取数据
- cout<<p->data;
- num++;//用来控制空格的输出,最后一位不用空格
- if(num<n)
- cout<<" ";
- if(p->l!=NULL)
- {
- rear++;
- pr[rear]=p->l;
- }
- if(p->r!=NULL)
- {
- rear++;
- pr[rear]=p->r;
- }
- }
- }
- //个人理解,rear是用来存取数据的,而front是跟着屁股后面来输出的
- int main()
- {
- int N;
- int j,k,l;
- cin>>N;
- n=N;
- for(j=0;j<N;j++)
- {
- cin>>btree[j];
- }
- for(j=0;j<N;j++)
- {
- cin>>ctree[j];
- }
- node *T=creattree(btree,ctree,n);
- print(T);
- return 0;
-
- }