赞
踩
新浪微博上有人发了某老板的作息时间表,表示其每天 4:30 就起床了。但立刻有眼尖的网友问:这时间表不完整啊,早上九点到下午一点干啥了?
本题就请你编写程序,检查任意一张时间表,找出其中没写出来的时间段。
输入格式:
输入第一行给出一个正整数 N,为作息表上列出的时间段的个数。随后 N 行,每行给出一个时间段,格式为:
hh:mm:ss - hh:mm:ss
其中 hh、mm、ss 分别是两位数表示的小时、分钟、秒。第一个时间是开始时间,第二个是结束时间。题目保证所有时间都在一天之内(即从 00:00:00 到 23:59:59);每个区间间隔至少 1 秒;并且任意两个给出的时间区间最多只在一个端点有重合,没有区间重叠的情况。
输出格式:
按照时间顺序列出时间表中没有出现的区间,每个区间占一行,格式与输入相同。题目保证至少存在一个区间需要输出。
输入样例:
8 13:00:00 - 18:00:00 00:00:00 - 01:00:05 08:00:00 - 09:00:00 07:10:59 - 08:00:00 01:00:05 - 04:30:00 06:30:00 - 07:10:58 05:30:00 - 06:30:00 18:00:00 - 19:00:00输出样例:
04:30:00 - 05:30:00 07:10:58 - 07:10:59 09:00:00 - 13:00:00 19:00:00 - 23:59:59
- //先将作息表中各时间段按照起始时间进行升序排序
- //再判断两个时间段之间是否有其它时间段,有就输出
- //首尾时间段另外考虑,作息表只有一个时间段另外考虑
- #include <iostream>
- #include <map>
- #include <vector>
- using namespace std;
-
- class Time {
- public:
- int hh;
- int mm;
- int ss;
- bool operator==(Time& t)
- {
- if (this->hh == t.hh && this->mm == t.mm && this->ss == t.ss)
- return true;
- else
- return false;
- }
- void print()
- {
- printf("%02d:%02d:%02d", this->hh, this->mm, this->ss);
- }
- };
-
- class cmp {
- public:
- bool operator()(Time a, Time b) const {
- if (a.hh != b.hh)
- return a.hh < b.hh;
- else if (a.mm != b.mm)
- return a.mm < b.mm;
- else
- return a.ss < b.ss;
- }
- };
-
- int main()
- {
- int n; cin >> n;
- map<Time, Time, cmp> time_temp;
-
- Time t1, t2;
- while (n--) {
- scanf("%d:%d:%d - %d:%d:%d", &t1.hh, &t1.mm, &t1.ss, &t2.hh, &t2.mm, &t2.ss);
- time_temp.insert(make_pair(t1, t2));
- }
-
- vector< pair<Time, Time> > time(time_temp.begin(), time_temp.end());
- if (time[0].first.hh != 0 || time[0].first.mm != 0 || time[0].first.ss != 0)
- { //作息表是否从00:00:00开始
- cout << "00:00:00 - ";
- time[0].first.print();
- cout << endl;
- }
- if (time.size() > 1) { //作息表内容至少要有两条(判断二者间是否有时间差)
- for (int i = 0; i < time.size() - 1; i++) {
- if (!(time[i].second == time[i + 1].first)) {
- time[i].second.print();
- cout << " - ";
- time[i + 1].first.print();
- cout << endl;
- }
- }
- }
- int temp = time.size() - 1;
- if (!(time[temp].second.hh == 23 && time[temp].second.mm == 59 && time[temp].second.ss == 59))
- { //作息表是不是于23:59:59结束
- time[temp].second.print();
- cout << " - 23:59:59" << endl;
- }
- return 0;
- }
注意事项:
如有问题,欢迎提出。
Copyright © 2003-2013 www.wpsshop.cn 版权所有,并保留所有权利。